AuthenticationType négocier NTLM

J'ai un et la même base de code utilisé sur 2 Différents sites postés sur un serveur /IIS 7.5/.

Pour une raison quelconque, quand je vérifie la propriété Identity.AuthenticationType Dans le code derrière le gestionnaire http, je vois NTLM pour 1 Site et négociations en direct pour un autre. Cela provoque des problèmes et j'ai besoin d'eux à la fois pour utiliser NTLM.

Pourriez-vous m'aider à comprendre pourquoi une telle différence? Jusqu'à présent, je vois que les deux sites IIS sont les mêmes, mais bien sûr, il y a au moins 1 La différence que je ne pouvais pas détecter.
Merci!

ÉDITER

j'ai utilisé
http://www.iis.net/ConfigRefer ... s/add
La référence contenant les instructions pour éliminer le fournisseur "Negotiate" de IIS. Cela ne m'a pas affecté. j'ai joué


appcmd.exe set config "Contoso" -section:system.webServer/security/authentication/windowsAuthentication /-"providers.[value='Negotiate']" /commit:apphost


Peut-être que j'ai fait quelque chose de mal, mais cela n'a pas aidé. Je vois toujours "Negotiate" comme AuthenticationType

J'ai un problème que j'ai défini les informations d'identification d'investissement web.config, Mais il ne les utilise pas. Au lieu d'utiliser les informations d'identification que je fournis, il utilise un utilisateur anonyme.

Et quelque chose d'étrange est que windowsAuthentication Désactivé. Je pensais que "Negotiate" Utilisé uniquement windowsAuthentication.
Invité:

Catherine

Confirmation de:

Les négociations utiliseront l'authentification NTLM ou Kerberos intérieurement.
Si le site est écrit Ntlm, alors seule l'authentification sera sélectionnée Ntlm.
Veuillez vérifier à la fois les sites et rendre l'authentification pour être la même.

Enzo

Confirmation de:

Windows L'authentification doit être activée et l'authentification anonyme est désactivée pour obtenir l'utilisateur fourni. /Je suppose que vous êtes sur l'authentification du domaine et que vous ne voulez pas retourner à un utilisateur anonyme si l'utilisateur n'a pas d'informations d'identification autorisées en utilisant windows auth/.

À IIS7.5, Pour voir les fournisseurs utilisés, cliquez sur l'authentification, cliquez avec le bouton droit de la souris sur Windows Authentification et sélectionner des fournisseurs. Vous aurez une liste de fournisseurs incluses, la commande est importante. Essayez de vous assurer qu'ils sont tous deux identiques /Dans votre cas il y a NTLM En haut de la liste/.

Désolé pour la réponse tardive!

Damien

Confirmation de:

La première chose que vous devez vérifier - Il s'agit de savoir s'il existe une différence entre les types d'authentification inclus pour chaque site.

La valeur par défaut n'est que l'anonymat.

Gaspard

Confirmation de:

Si votre version Internet Information Server /IIS/ égal 7.0, Regardez dans le fichier <%SystemDrive%>/Windows/System32/inetsrv/config/ApplicationHost.config Une telle section:


<system.webserver>
<security>
<authentication>
<windowsauthentication enabled="false">
<providers>
<add value="Negotiate"></add>
<add value="NTLM"></add>
</providers>
</windowsauthentication>
</authentication>
</security>
</system.webserver>


Documentation pour
http://www.iis.net/configrefer ... iders
Windows Peut contenir des informations plus détaillées.

Question
https://coderoad.ru/16222946/
contient des instructions pour l'enlèvement Negotiate, que j'ai trouvé utile quand j'ai essayé d'allumer à nouveau Negotiate.

Pour répondre aux questions, connectez-vous ou registre