Erreur: Impossible d'autoriser le module "babel-loader"

J'essaie de commencer webpack Sur mon script postinstall dans mon package.json, Quand je clique sur heroku, Mais j'obtiens l'erreur suivante.


ERROR in Entry module not found: Error: Cannot resolve module 'babel-loader' in /tmp/build_6cb4b10367d9382367ab72f2e2f33118


Lorsque je démarre la commande localement, je n'ai aucun problème. Vous trouverez ci-dessous la configuration de ma webPack - j'ai essayé d'utiliser resolveLoader, Pour corriger le problème de la permission, mais en vain non?


var path = require/'path'/;
var webpack = require/'webpack'/;

var config = {
entry: path.resolve/__dirname, './app/main.js'/,
output: {
path: path.resolve/__dirname, 'dist'/,
filename: 'bundle.js'
},
module: {
loaders: [
{
test: /\.js$/,
exclude: /node_modules/,
loader: 'babel-loader'
},
{
test: /\.less$/,
loader: 'style!css!less'
}]
},
resolve: {
extensions: ['', '.js', '.jsx', '.less'],
modulesDirectories: [
'node_modules'
]
},
resolveLoader: {
root: path.resolve/__dirname, 'node_modules'/
},
plugins: [
new webpack.optimize.UglifyJsPlugin/{minimize: true}/
]
};

module.exports = config;


Avez-vous des suggestions? Merci
Invité:

Hannah

Confirmation de:

J'ai découvert pourquoi. Je n'avais pas une chatte babylonienne ou le pilier babylonien de la principale dans mon package.json. L'ajout d'erreur corrigée.


"devDependencies": {
"babel": "^5.8.23",
"babel-core": "^5.0.0",
"babel-loader": "^5.3.2"
}

Christine

Confirmation de:

Dans mon cas, j'ai manqué le chargeur de démarrage lorsqu'il est installé, assurez-vous que vous l'avez installé.

Babylon-chargeur

NOT

Chargeur de bable

Felix

Confirmation de:

Dans mon cas, j'ai essayé l'équipe:


$ npm install babel-loader --save


Et a continué à corriger rest Sur la base du rappel de la console, et il a corrigé le problème:

"ERROR Module d'entrée non trouvé: Erreur: Impossible d'autoriser 'babel-loader'"

David

Confirmation de:

j'utilise yarn et webpacker pour le projet rails + react.

Je sais que tout le monde ne peut pas mettre à jour toutes ses dépendances sans les briser, mais pour moi en ajoutant running
yarn upgrade

Corrigé cette erreur.

C'était seulement avec
@babel/core

Dans ma configuration
dependencies

, car
babel-loader

Inclus comme dépendance webpacker.

Daniel

Confirmation de:

J'ai supprimé le dossier yarn.lock et node_modules, Puis abaissé babel-loader dans votre devDependencies à package.json, Puis j'ai redémarré yarn, Et il fonctionne.

Francis

Confirmation de:

Dans certains cas, lorsqu'il est déployé dans l'environnement de travail /Par exemple, en utilisant Rails Webpacker/ Dépendances dev Ne pas charger. Donc le chargeur de babel dans
devDependencies

ne fonctionnera pas.

Effectivement de sens , Quel babel-loader sera placé dans
dependencies

, pas b.
devDependencies

, Parce qu'il est utilisé dans le code de fabrication lui-même. Les seuls paquets qui devraient être dans
devDependencies

, - Ce sont ceux qui fonctionnent pendant le processus de développement, tels que des tests et des rayures.

Gilles

Confirmation de:

J'avais mon propre

devDependencies

, Et il n'a pas travaillé, je l'ai changé à

Dépendances

, Et il a finalement gagné!

Catherine

Confirmation de:

Utilisant yarn 2 webpack 4 Ne peut pas résoudre le chargeur de démarrage. ou mettre à jour à webpack 5

Je devais utiliser PnPify, Faire fonctionner.


yarn pnpify webpack

Constantine

Confirmation de:

J'ai eu une erreur similaire lorsque vous travaillez avec l'application

Rails 6

.

Je pense que le problème était que le package de nœuds

Babel-loader

Il n'a pas été installé correctement ou un fichier exécutable n'a pas pu être trouvé par l'application.

Tout ce que je devais faire est de mettre à jour les packages de nœuds dans l'application, en cours d'exécution:


yarn upgrade


Voici mon
devDependencies

dans mon
package.json

Déposer:


"devDependencies": {
"webpack": "^4.43.0",
"webpack-cli": "^3.3.12",
"webpack-dev-server": "^3.11.0


Noter

: Je n'ai pas besoin d'inclure un package de nœuds Babel-loader dans la liste devDependencies, Afin qu'il a travaillé.

Tout est tout.

J'espère que cela aidera

Pour répondre aux questions, connectez-vous ou registre