Apache "Le client est rejeté par la configuration du serveur", malgré la permission d'accéder au catalogue. (configuration vhost)

dans Apache sur Ubuntu J'ai installé un hôte virtuel, mais dans le navigateur tout le temps donne une erreur «403 L'accès est refusé"; Le magazine dit "

Le client est rejeté par la configuration du serveur: / home / remix /

".

À la recherche d'une solution sur Internet, j'ai trouvé de nombreux messages sur l'accès aux catalogues. (Permettre à tous, etc.), Mais pour autant que je sache, je l'ai déjà fait. DANS

httpd-vhosts.conf

Voici le code:

NameVirtualHost *:80

<virtualhost *:80="">
ServerAdmin webmaster@dummy-host.example.com
DocumentRoot "/opt/lampp/htdocs/"
ServerName localhost
ServerAlias localhost
ErrorLog "logs/dummy-host.example.com-error_log"
CustomLog "logs/dummy-host.example.com-access_log" common
</virtualhost>
<virtualhost *:80="">
ServerAdmin webmaster@localhost
DocumentRoot "/home/remix/"
ServerName testproject
ServerAlias testproject
<directory "="" home="" remix="">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</directory>
</virtualhost>

J'ai aussi ajouté

127.0.0.1    testproject

déposer. / etc / hosts.

De plus, le dossier / home / remix / Contient le fichier. index.html, UN B. httpd.conf Inclus vhosts.

Je ne vois pas quelque chose?

Éditer:

Ceci est un enregistrement Apache error_log:

[Sat Aug 18 09:15:32.666938 2012] [authz_core:error] [pid 6587] 
[client 127.0.0.1:38873] AH01630: client denied by server configuration: /home/remix/
Invité:

Blanche

Confirmation de:

Modifier la configuration d'autorisation:

<directory home="" remix=""></directory>
#...
Order allow,deny
Allow from all


... À la version du même Apache 2.4.

<directory home="" remix=""></directory>
#...
Require all granted


Aperçu
http://httpd.apache.org/docs/2.4/upgrading.html
Pour plus d'informations sur d'autres modifications dont vous pourriez avoir besoin et garder à l'esprit que la plupart des exemples de configuration et une assistance que vous trouvez dans Google (ainsi que sur ce site), faire référence à 2.2.

Hannah

Confirmation de:

Vérifiez les droits d'accès au répertoire. Je peux faire valoir qu'il est configuré de refuser d'accéder à qui que ce soit, par exemple:

$ ls -ld /home/remix
drwx------ 92 remix remix 4096 Aug 17 22:59 /home/remix

Si tu vois

drwx------

C'est alors c'est ça. Corrigez-le en exécutant:

chmod a+x /home/remix

Christine

Confirmation de:

Assurez-vous que l'utilisateur fonctionne

httpd

Le service a accès à ces répertoires.

Agathe

Confirmation de:

"Le client est interdit par la configuration du serveur" signifie que le serveur lui-même interdit le fichier. Linux, mais non Apache.

Si la fourniture d'accès en changeant la permission / la possession / L'adhésion au groupe ne résout pas le problème, la cause de la route peut être SELinux, interdire l'accès à tout dossier qui n'a pas de contexte approprié SE Linux, Comme décrit dans
http://www.terminalinflection. ... inux/
.

Si vous désactivez temporairement SELinux, Suivant

setenforce 0

Fait du fichier disponible

Alors que la réinclusion SELinux par exécution

setenforce 0

Encore une fois rend le fichier inaccessible

Ensuite, l'accès est probablement interdit. SELinux Quels que soient les droits d'accès au dossier.

Dominique

Confirmation de:

Un autre simple (Mais l'erreur délicate), qui peut causer ce problème pour les gens - C'est quand les annuaires personnalisés ne sont pas dans / home / *, Et ailleurs, par exemple. / nethome / *

Fourni userdir.conf Contient quelque chose comme ça: (Mais S. Userdir: disabled)

$ cat /etc/httpd/conf.d/userdir.conf 
<ifmodule mod_userdir.c="">
UserDir enabled
UserDir public_html
</ifmodule>
<directory "="" *="" home="" public_html"="">
AllowOverride FileInfo AuthConfig Limit Indexes
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
Require method GET POST OPTIONS
</directory>

La spécification de répertoire suggère ~ user == / home / user. Il suffit de modifier ou d'ajouter une spécification de répertoire pour laquelle les répertoires de maison de l'utilisateur sont réellement localisés.

Assez évident, mais j'avais besoin de temps pour comprendre !! :-P ESPRIT!

par exemple ~ utilisateur == / nethome / utilisateur

<directory "="" *="" nethome="" public_html"="">
AllowOverride All
Options MultiViews Indexes Includes FollowSymLinks
Require all granted
</directory>

Voir également des informations plus détaillées sur l'autorisation ouverte dans ce répertoire dans son ensemble.

Christine

Confirmation de:

Dans mon cas, j'ai ajouté la demande (phpMemcacheAdmin), mais n'a pas pris soin d'ajouter des montages à la pile de déploiement, alors ils n'étaient même pas (Matériel kubernetes) Quand commence. J'ai passé une heure pour éliminer les fonctionnalités obliques supplémentaires et changer les autorisations et j'ai finalement découvert qu'ils n'étaient même pas.

Si vous essayez de déployer k8s, Vérifiez deux fois si vous vous avez (Si vous utilisez hostPath):

...
volumeMounts:
- mountPath: /opt/phpMemcacheAdmin
name: memcached-admin
...
- hostPath:
path: /...../opt/phpMemcacheAdmin
type: ""
name: memcached-admin

Pour répondre aux questions, connectez-vous ou registre