Service de contenu statique avec Apache2

Je suis vraiment nouveau dans apache2 et précédemment travaillé avec Nginx. J'essaie d'utiliser un pseudonyme dans apache2 Pour entretenir du contenu statique. Commençons par un exemple simple.

J'ai essayé
https://access.redhat.com/solutions/67298
De, et cela n'a pas non plus fonctionné. Conseil?

000-default.conf:

<virtualhost *:80="">
ServerAdmin webmaster@localhost
ServerName 13.67.35.134
Alias /static /home/ubuntu/static
<directory home="" static="" ubuntu=""></directory>
Options FollowSymLinks

ProxyPass / [url=http://127.0.0.1:5000/]http://127.0.0.1:5000/[/url]
</virtualhost>

Je l'ai également essayé avec des citations basées sur cette
https://serverfault.com/questi ... lhost
:

<virtualhost *:80="">
ServerAdmin webmaster@localhost
ServerName 13.67.35.134
Alias /static "/home/ubuntu/static"
<directory "="" home="" static"="" ubuntu="">
Options FollowSymLinks
</directory>
ProxyPass / [url=http://127.0.0.1:5000/]http://127.0.0.1:5000/[/url]
</virtualhost>

j'ai logo.png, situé à

/home/ubuntu/static/logo.png

alias_module inclus:

$ apache2ctl -M | grep alias
alias_module (shared)

Quand je tape 13.67.35.134/static/logo.png, Je reçois

404

, c'est access.log

[26/Jan/2018:02:31:02 +0000] "GET /static/logo.png HTTP/1.1" 404 423 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36"

Décision

remercier @AndrewSchulman Pour le fait qu'il a indiqué que Proxy Pass Dans mon fichier 000-default.conf prive l'accès à mon contenu statique.
Invité:

Babette

Confirmation de:

Si vous n'avez pas d'autre serveur Web fonctionnant localhost: 5000 (Et je ne sais pas pourquoi vous le faites, à l'exception des tests, je suppose), Vous devriez supprimer

ProxyPass / [url=http://127.0.0.1:5000/]http://127.0.0.1:5000/[/url]

directif.

Pour répondre aux questions, connectez-vous ou registre