sur debian, lighttpd apache2 Utiliser le port 80, lighttpd Problèmes: L'adresse utilise déjà une erreur

L'autre jour, j'ai acheté le serveur linode (linode.com). J'ai essayé de commencer lighttpd et apache2 sur un port utilisant lighttpd Pour les fichiers statiques. Dans la mesure où linode Fournit une seule adresse ipv4, J'ai essayé de lier lighttpd à l'adresse ipv6. C'est là que j'ai reçu la même erreur à chaque fois: je ne peux pas se lier au port [ipv6] 80 L'adresse est déjà utilisée. J'ai essayé de lier l'adresse ipv4. Tout a gagné. Aidez-moi s'il vous plaît, cela me rend fou pour les deux derniers jours.

Mon fichier. lighttpd.conf: (l'adresse ipv6 Nerner)

server.modules = (
"mod_access",
"mod_alias",
"mod_compress",
"mod_redirect",
# "mod_rewrite",
)

server.document-root = "/var/www"
server.upload-dirs = ( "/var/cache/lighttpd/uploads" )
server.errorlog = "/var/log/lighttpd/error.log"
server.pid-file = "/var/run/lighttpd.pid"
server.username = "www-data"
server.groupname = "www-data"
server.port = 80
server.bind = "2600:3c02::0000"
server.use-ipv6 = "enable"
#server.pid-file = "/var/run/lighttpd.pid"


index-file.names = ( "index.php", "index.html", "index.lighttpd.html" )
url.access-deny = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

compress.cache-dir = "/var/cache/lighttpd/compress/"
compress.filetype = ( "application/javascript", "text/css", "text/html", "text/plain" )

# default listening port for IPv6 falls back to the IPv4 port
#include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.assign.pl"
include_shell "/usr/share/lighttpd/include-conf-enabled.pl"


### ipv6 ###
$SERVER["socket"] == "[2600:3c02::0000]:80" {
# accesslog.filename = "var/log/lighttpd/ipv6/access.log"
# server.document-root = "/var/www/"
# server.error-handler-404 = "/index.php?error=404"
}

Et message d'erreur: il est impossible de se lier au port, 2600: 3c02 :: 0000 L'adresse est déjà utilisée.
Invité:

Blanche

Confirmation de:

Si vous souhaitez conserver des fichiers statiques avec lighttpd / nginx et dynamique en utilisant apache, Vous devez courir lightttpd / nginx Sur le port 80 (ou 443, si un ssl), et apache sur un autre. Ensuite, vous mettez en place lightttpd / nginx comme un proxy pour envoyer tout ce qui n'est pas statique, dans apache sur un port alternatif. Vous pouvez trouver de nombreux exemples.

Agathe

Confirmation de:

Vous liez à K.

[2600:3c02::0000]:80

avec

server.port                 = 80
server.bind = "2600:3c02::0000"

et

$SERVER["socket"] == "[2600:3c02::0000]:80" {
...
}

Cela signifie que vous effectuez deux fois la liaison à la même adresse. Effacer

$SERVER["socket"]

Bloc, et tout devrait être en ordre.

(

Éditer

: Donc, vous obtenez ce qu'ils ont demandé à propos de; Mais je doute de votre "Installation" En général, une bonne idée; Comme Halfara, un serveur Web doit se connecter à un autre par procuration; En règle générale, celle qui sert des fichiers statiques doit être publiquement visible par des processus autres cachés)

Pour répondre aux questions, connectez-vous ou registre