nginx: [Emerg] directif user Non autorisé B. /etc/nginx/sites-enabled/nginx.conf:1

J'essaie d'installer Oxidized au serveur. Ubuntu 18.04 LTS. j'utilise Nginx En tant que serveur WAB, et maintenant, ils disent que je dois changer le fichier "/etc/nginx/nginx.conf", Ce que j'ai fait, correctement suivant la documentation présentée sur la page github Logiciel. Mais quand je veux exécuter la commande

sudo nginx -t

Le serveur le soulève:

nginx: [emerg] "user" directive is not allowed here in /etc/nginx/sites-enabled/nginx.conf:1

Donc j'ai déjà essayé de faire

sudo chown -R /etc/nginx/sites-enabled

En espérant que cela peut changer quelque chose. Voici mon nginx.conf:

user oxidized oxidized;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;
}

http {

##
# Basic Settings
##

log_format main '$remote_addr - $remote_user [$time_local] "$request"'
'$status $body_bytes_sent "$http_referer"'
'"$http_user_agent" "$http_x_forwarded_for"';

access_log /var/log/nginx/access.log main;

sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
types_hash_max_size 2048;
# server_tokens off;

# server_names_hash_bucket_size 64;
# server_name_in_redirect off;

include /etc/nginx/mime.types;
default_type application/octet-stream;

##
# SSL Settings
##

ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
ssl_prefer_server_ciphers on;

##
# Logging Settings
##

access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;

##
# Gzip Settings
##

gzip on;

# gzip_vary on;
# gzip_proxied any;
# gzip_comp_level 6;
# gzip_buffers 16 8k;
# gzip_http_version 1.1;
# gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/ja$

##
# Virtual Host Configs
##

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;

server {
listen 80;
server_name oxidized.test.com www.oxidized.test.com;
return 301 https://$server_name$request_uri;
root /usr/share/nginx/html;

auth_basic "Restricted Access";
auth_basic_user_file /etc/nginx/.htpasswd;

# Load configuration files for the default server block.
include /etc/nginx/default.d/*.conf;

location / {
proxy_pass [url=http://127.0.0.1:8888/;]http://127.0.0.1:8888/;[/url]
}

error_page 404 /404.html;
location = /40x.html {
}

error_page 500 502 503 504 /50x.html;
location = /50x.html {
}
}
}

Je ne pense pas que j'ai fait des erreurs, mais si quelqu'un pouvait m'aider à trouver ce que le problème serait bon. S'il vous plaît répondez-moi dès que possible.
Invité:

Pour répondre aux questions, connectez-vous ou registre