Site Internet Drupal Désactivé: la connexion est refusée

J'ai une copie locale Drupal 6, Lequel hier a bien fonctionné bien. Mais aujourd'hui, j'essaie d'aller sur mon site, appelons-le
http://testsite.local
. Sur chaque page, y compris
http://testsite.local/user
, Je reçois cette erreur:

Site Web non en ligne Actuellement, le site n'est pas disponible en raison de problèmes techniques. Merci d'essayer plus tard. Merci pour votre compréhension.

Si vous desservez ce site, vérifiez les paramètres de votre base de données dans le fichier. settings.php Et assurez-vous que votre serveur de base de données de fournisseur d'hébergement est en cours d'exécution. Pour plus d'aide, voir le manuel ou contactez votre fournisseur d'hébergement.

S'il vous plaît noter qu'il n'y a aucune erreur MySQL. Je ne trouve qu'une seule page sur laquelle il n'y a pas cette erreur:
http://testsite.local/install.php
. Cette page a un message d'erreur:

Impossible de se connecter au serveur de base de données MySQL. MySQL Rapporte le message suivant:

Connexion rejetée

.

Êtes-vous sûr d'avoir un identifiant et un mot de passe corrects?

Êtes-vous sûr que vous avez entré le nom correct de l'hôte de la base de données?

Êtes-vous sûr que le serveur de base de données fonctionne?

Pour plus d'aide, voir Guide d'installation et de mise à niveau. Si vous ne savez pas ce que signifient ces termes, vous devez probablement contacter votre fournisseur d'hébergement.

Cependant, l'autre site local fonctionne bien avec la même base de données et je peux vous connecter à la base de données à l'aide de la ligne de commande. Je suis presque sûr que j'ai les bonnes autorisations, car tout a fonctionné dans le passé:

$ mysql --host=localhost --user=testuser --password=testpassword testdb
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 19
Server version: 5.5.11-log Source distribution

Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> SHOW GRANTS FOR CURRENT_USER();
+-------------------------------------------------------------------------------------------------------------------------------------+
| Grants for testuser@localhost |
+-------------------------------------------------------------------------------------------------------------------------------------+
| GRANT USAGE ON *.* TO 'testuser'@'localhost' IDENTIFIED BY PASSWORD 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX' |
| GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER, LOCK TABLES ON `testdb`.* TO 'testuser'@'localhost' |
+-------------------------------------------------------------------------------------------------------------------------------------+
2 rows in set (0.03 sec)

Mon

settings.php

utilise les mêmes informations d'identification:

$db_url = 'mysqli://testuser:testpassword@localhost/testdb';

Je ne peux pas comprendre ce qui s'est passé. S'il vous plaît aider!
Invité:

Babette

Confirmation de:

Vérifier

sites

catalogue. Une raison commune de cela peut être la structure des catalogues, qui devrait ressembler à ceci:

sites/
default/
settings.php
somedomain.com -> default

Mais il a été enregistré dans des irrégulaires SCCS (et retour et retour à travers un client sans cerveau), Donc, le lien symbolique a été traité comme un autre répertoire, alors vous avez maintenant:

sites/
default/
settings.php
somedomain.com/
settings.php

Et, bien sûr, vous ne changez probablement que

default/settings.php

, Comme il s'agit de la seule option raisonnable pouvant être modifiée lorsque vous n'utilisez pas de multisites. Néanmoins,

cadeau

La décision ici n'est pas de corriger un autre fichier. settings.php ou restaurer un lien symbolique, puis supprimer simplement "somedomain.com"; Il n'ajoute rien à votre configuration.

Je l'ai vu d'une autre manière: très, très gros (près 500 Rangée) settings.php avait vraiment eu

deux


$db_url

à l'intérieur. Le second, bien sûr, "gagné". Parlez de choses que vous ne pensez pas regarder!

Catherine

Confirmation de:

Vous devez vérifier deux fois si votre serveur l'utilise vraiment

settings.php

déposer.

Vous pouvez utiliser

find

ou

locate

Si vous travaillez dans l'environnement Linux.

Vous pouvez aussi essayer de renommer / Déplacez le fichier de configuration vers un autre emplacement et voyez si le message d'erreur changera.

Ce type d'erreur est probablement causé par une configuration incorrecte.

Dominique

Confirmation de:

Essayer: 'mysqladmin flush-hosts'. Vérifiez également vos droits d'utilisateur mysql. Peut-être que vous n'autorisez pas l'accès à cette base de données? Vérifiez également les journaux entre ces serveurs.

Pour répondre aux questions, connectez-vous ou registre