Installer PhantomJS sur le MacOs 10.11 El Captian

Je ne peux pas installer phantomJs dans votre macbook Après la mise à niveau vers 10.11 /El Capitan/.

Chaque fois que j'essaie de l'installer avec homebrew, Il me donne cette erreur:


$ brew install phantomjs
phantomjs: OS X Yosemite or older is required.
Error: An unsatisfied requirement failed this build.
Invité:

Agathe

Confirmation de:

https://github.com/Homebrew/ho ... 71357
, si tu as npm, Vous pouvez l'installer:


npm install -g phantomjs-prebuilt


Maintenant que le problème est résolu, vous pouvez
http://phantomjs.org/download.html
.

Emilie

Confirmation de:

noter que :


npm install -g phantomjs


Sera installé
v1.9.8


Dernière version préliminaire
v2.0.1

Fonctionne correctement sur 10.11 El Captian
https://github.com/Vitallium/p ... 2.0.1
.

Juste copier
bin/phantomjs

Du chargement B.
/usr/local/bin/

/ou n'importe où/ Sur ton ordinateur.

Catherine

Confirmation de:

brew update


ensuite


brew install phantomjs

Gregoire

Confirmation de:

Installez-le Homebrew ou MacPorts


brew install phantomjs


ou


port install phantomjs


Vérifiez la version avec:
phantomjs --version


Qui installera la dernière version. Actuellement:
2.1.1


Ma version Mac OSX:
OS X El Capitan - Version 10.11.6


Merci!

Emilie

Confirmation de:

Le moyen le plus rapide et le plus simple d'installer autonome phantomjs /Testé par Mac OSX El Captian/ /utilisant brew ou macports Pour l'installation prend trop de temps, car ils vont installer le tout qt Et d'autres forfaits/

Téléchargez et déballer phantomjs-2.0.0-macosx.zip de
http://phantomjs.org/download.html

Installer le brasserie UPX par

UPX en -d. phantomjs-2.0.0-macosx/bin/phantomjs

Si vous n'avez pas déballé phantomjs par upx, Ça va arriver “killed -9” erreur
https://coderoad.ru/28267809/

Ajouter phantomjs au chemin du système dans Terminal: sudo nano /etc/paths

Écho $PATH

Ajoutez votre catalogue / phantomjs-2.0.0-macosx/bin jusqu'à la fin

Cliquez sur control-x, quitter.

Entrer “Y”, Pour enregistrer le tampon modifié.

Redémarrer terminal

Terminal: phantomjs-v Vous montre une version phantomjs, S'il est correctement installé

Enzo

Confirmation de:

Si cela ne fonctionne pas, essayez:

Installer le brasserie npm


npm install phantom phantomjs -g

Emile

Confirmation de:

Dernier fichier binaire publié /2.1.1/ pour Mac Il a toutes les dépendances incluses dans le fichier binaire. Ça marche hors de la boîte
http://phantomjs.org/download.html

Pour répondre aux questions, connectez-vous ou registre