Impossible de forcer le navigateur à demander un certificat client (Certificats sur Apache)

je veux Apache Certification des clients vérifiée avant de permettre à l'utilisateur d'aller sur le site Web.

À Chrome mon erreur:

192.168.2.57 didn’t accept your login certificate, or one may not have been provided.
Try contacting the system admin.
ERR_BAD_SSL_CLIENT_AUTH_CERT`

À Firefox mon erreur:

An error occurred during a connection to 192.168.2.57. SSL peer was unable to negotiate an acceptable set of security parameters. 
Error code: SSL_ERROR_HANDSHAKE_FAILURE_ALERT`

Je pense que le problème est qu'il n'est même pas suggéré de fournir un certificat client. Comment puis-je l'activer dans les deux navigateurs?

Autres informations: Mes centres de certification racine et intermédiaire sont stockés sur Apache. Ils ont signé mon certificat de site et mes certificats clients qui sont également stockés sur Apache. Tous ces certificats (Ca racine, ca, serveur et client intermédiaire, serveur et client) Ils ont été téléchargés sur mon navigateur.

Ma configuration Apache:

<ifmodule mod_ssl.c="">
<virtualhost 192.168.2.57:443="">

ServerName 192.168.2.57:443
DocumentRoot /var/www
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined


SSLEngine On
SSLCertificateFile "/etc/apache2/ssl/ca/intermediate/certs/AlexSite.cert.pem"
SSLCertificateKeyFile "/etc/apache2/ssl/ca/intermediate/private/AlexSite.key.pem"
SSLProtocol TLSv1 TLSv1.1

SSLCACertificateFile "/etc/apache2/ssl/ca/intermediate/certs/intermediate.cert.pem"


<directory var="" www=""></directory>
Options Indexes FollowSymLinks MultiViews
DirectoryIndex /cgi-bin/index.html

AllowOverride None
Order allow,deny
Allow from all

AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On

SSLVerifyClient require
SSLVerifyDepth 1



Alias "/mysql-files/" "/var/lib/mysql-files/"
<directory "="" lib="" mysql-files="" var="">
Require all granted
Options +Indexes
</directory>

ScriptAlias /cgi-bin/ /var/www/cgi-bin/
<directory cgi-bin="" var="" www="">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
AddHandler cgi-script .cgi .py
</directory>
<filesmatch "\.(cgi|shtml|phtml|php)$"="">
SSLOptions +StdEnvVars
</filesmatch>
<directory cgi-bin="" lib="" usr="">
SSLOptions +StdEnvVars
</directory>

BrowserMatch "MSIE [2-6]" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown

</virtualhost>
</ifmodule>`
Invité:

Gaetan

Confirmation de:

J'ai compris. Dans mes paramètres Apache J'ai changé:


SSLCACertificatePath

à

~~~~~~/ca/certs/ca.cert.pem


SSLVerifyDepth 1

à

SSLVerifyDepth 10

Et surtout, j'ai changé, j'ai transformé mes certificats clients avec pem sur le pfx

Pour répondre aux questions, connectez-vous ou registre