Problème avec le paquet Ubuntu 10.10 et exigences de passagers

J'essaie de forcer le passager à travailler avec
http://en.wikipedia.org/wiki/L ... at.29
(Maverick Meerkat), Et j'ai eu un problème. Il semble que l'installateur Passenger Ne reconnaît pas le paquet virtuel. Je reçois une telle erreur:

Le code:

passenger-install-apache2-module
...
* OpenSSL support for Ruby... not found
...

Et puis il dit: courez-le:

* To install OpenSSL support for Ruby:
Please run apt-get install libopenssl-ruby as root.

Lorsque j'exécute la commande ci-dessus, il fait référence au paquet libruby:

sudo apt-get install libopenssl-ruby
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libruby' instead of 'libopenssl-ruby'
libruby is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 43 not upgraded.

Quand je regarde les détails pour libruby, Il dit qu'il fournit libopenssl-ruby:

Le code:

Provides: libbigdecimal-ruby, libcurses-ruby, libdbm-ruby, libdl-ruby, libdrb-ruby, liberb-ruby, libgdbm-ruby, libiconv-ruby, libopenssl-ruby, libpty-ruby, libracc-runtime-ruby, libreadline-ruby, librexml-ruby, libsdbm-ruby, libstrscan-ruby, libsyslog-ruby, libtest-unit-ruby, libwebrick-ruby, libxmlrpc-ruby, libyaml-ruby, libzlib-ruby

Et quand je relance le programme d'installation Passenger, Il donne la même erreur:

Le code:

passenger-install-apache2-module
...
* OpenSSL support for Ruby... not found
...

Faites-moi savoir si vous avez besoin d'informations supplémentaires. Comment le réparer?
Invité:

Christine

Confirmation de:

Vous n'avez probablement pas compilé de soutien SSL Quand installé Ruby. Cela pourrait arriver parce que vous n'avez pas eu

libssl-dev

ou

openssl

Les colis sont définis en premier. Je recommande d'installer ces packages, puis de recompiler votre version Ruby Et répéter la tentative.

Pour répondre aux questions, connectez-vous ou registre