Comment me mettre à jour PHP 5.3 avant que PHP 5.4.6 dans Ubuntu?

Y a-t-il un moyen facile d'obtenir la dernière version PHP? J'ai essayé de mettre à jour mon colis, mais il n'a toujours aucune version 5.4.6 ... Si quelqu'un sait comment le faire rapidement, est-il possible de le partager ici?

J'ai essayé de compiler de la source, mais je reçois constamment:

 configure: error: Cannot find OpenSSL's <evp.h>.

Dans mon

./configure

J'ai spécifié où

evp.h

est un,

--with-openssl=/usr/include/openssl \..

, Mais ça me donne toujours cette erreur



</evp.h>
Invité:

Christine

Confirmation de:

Installation PHP 5.4. * DANS Ubuntu 12.04

Il suffit d'ajouter un référentiel PPA:

sudo add-apt-repository ppa:ondrej/php5-oldstable

Et l'installer:

sudo apt-get update
sudo apt-get install php5

Vous devrez peut-être installer add-apt-repository dans Ubuntu 12.04. Pour ce faire, exécutez la commande:

sudo apt-get install python-software-properties

Autres nouvelles versions

Pour PHP 5.5 (actuellement 5.5.30) Au lieu de cela, ajoutez un référentiel PPA:

sudo add-apt-repository ppa:ondrej/php5

Pour PHP 5.6 (actuellement 5.6.14) Au lieu de cela, ajoutez un référentiel PPA:

sudo add-apt-repository ppa:ondrej/php5-5.6

Giselle

Confirmation de:

Regardez haut à la page suivante pour mettre à jour PHP 5.4 À Ubuntu

[url=http://www.zimbio.com/Ubuntu+Linux/articles/D_AsJR2qAL6/How+Upgrade+PHP+5+4+Ubuntu]http://www.zimbio.com/Ubuntu%2 ... buntu[/url]

Vous pouvez mettre à jour avec la commande apt-get dans le terminal. Ouvrez le terminal et connectez-vous en tant qu'utilisateur su. Ensuite, essayez la commande suivante à mettre à jour.

add-apt-repository ppa:ondrej/php5
apt-get update
apt-get install php5

Si vous essayez d'utiliser des outils utilisateur locaux, utilisez sudo avant toutes les équipes ...

ATTENTION:

- Il sera également automatiquement mis à jour Apache (À présent 2.4), Ce qui a des conséquences supplémentaires, c'est-à-dire Il y a de gros changements dans la configuration entre Apache 2.2. et 2.4, Qu'est-ce qui empêchera le début du service Apache après!

Giselle

Confirmation de:

Si des référentiels officiels Ubuntu Pas à jour (Et je ne pense pas qu'ils soient toujours mis à jour, la dernière version disponible PHP doit être 5.3.x), Vous devrez télécharger les fichiers source et les compiler vous-même.

Voir:
http://www.php.net/manual/en/install.unix.php

Pour répondre aux questions, connectez-vous ou registre