Serveur CloudLinux ne télécharge pas

J'ai un serveur cPanel, qui fonctionne Cloud Linux, Ceci est un serveur dédié sur lequel il a été fonctionné à l'origine. CentOS 6.4 et SoftRaid 1. Je l'ai converti sur CloudLinux Après une nouvelle réinstallation. Jusqu'à présent, je n'avais pas besoin de le redémarrer. Tout s'est bien passé, mais quand j'ai redémarré le serveur, il s'est éteint, mais je n'ai pas revenu. Le fournisseur le transféra au mode de récupération, car

Je ne peux pas utiliser KVM ou IPMI.

J'ai vérifié l'équipement et tout est en ordre. J'ai essayé de réinstaller GRUB, Mais cela ne change rien. Le serveur n'est toujours pas chargé. Je n'ai vraiment pas d'idées pour le moment. Le fournisseur est non géré, en dernier recours, laissez la réinstallation.

J'ai utilisé ce tutoriel pour réinstaller GRUB:
http://www.adminlinux.org/2009 ... .html
ÉDITER:

Le fournisseur m'a dit qu'il est affiché à l'écran lors du chargement:

*An error occurred during the file system check*
*Dropping you to a shell; the system will reboot*

J'ai passé une légère étude et j'ai besoin de courir fsck.

Quand j'essaie de courir fsck / dev / sda1, Je reçois ce qui suit:

root@rescue [/]# fsck /dev/sda1
fsck from util-linux-ng 2.17.2
fsck: fsck.linux_raid_member: not found
fsck: Error 2 while executing fsck.linux_raid_member for /dev/sda1

C'est lorsque le disque est monté, j'ai essayé de le démonter,

root@rescue [/]# fsck /dev/sda1
fsck from util-linux-ng 2.17.2
/dev/sda1 is in use.
Aborted

Je fais tout cela en mode secours.

j'ai 2 disque 1 Tb chaque B. Raid 1, ici fstab:

# <file system=""> <mount point=""> <type> <options> <dump> <pass>
/dev/md1 / ext3 errors=remount-ro,usrjquota=quota.user,jqfmt=vfsv0 0 1
/dev/md3 /home ext3 usrjquota=quota.user,jqfmt=vfsv0 1 2
/dev/sda2 swap swap defaults 0 0
/dev/sdb2 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
tmpfs /dev/shm tmpfs noexec,nosuid 0 0
devpts /dev/pts devpts defaults 0 0
/tmp_fs /tmp ext3 noexec,nosuid,loop,rw 1 1

Rafraîchir:

Comme suggéré Bittylicious, J'ai exécuté des commandes et voici les résultats:

root@rescue:~# mdadm --assemble /dev/md1 /dev/sda1 /dev/sdb1
mdadm: /dev/sda1 is busy - skipping
mdadm: /dev/sdb1 is busy - skipping

Ensuite, j'ai suggéré que le raid soit déjà assemblé et j'ai fait:

root@rescue:~# fsck /dev/md1
fsck from util-linux 2.20.1
e2fsck 1.42.5 (29-Jul-2012)
/: recovering journal
Setting free inodes count to 9410644 (was 9410650)
Setting free blocks count to 35082532 (was 35082538)
/: clean, 190380/9601024 files, 3317196/38399728 blocks

Mettre à jour №2:

Voici le résultat du montage:

root@rescue:~# mount
none on / type tmpfs (rw,relatime)
none on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
198.27.85.63:/home/pub/rescue.v7 on /nfs type nfs (ro,relatime,vers=3,rsize=8192,wsize=8192,namlen=255,hard,nolock,proto=udp,port=2049,timeo=11,retrans=3,sec=sys,local_lock=all,addr=198.27.85.63)
198.27.85.63:/home/pub/pro-power on /power type nfs (ro,nodev,relatime,vers=3,rsize=8192,wsize=8192,namlen=255,hard,nolock,proto=udp,port=2049,timeo=11,retrans=3,sec=sys,local_lock=all,addr=198.27.85.63)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev type tmpfs (rw,relatime,size=10240k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=807512k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=1615020k)
rpc_pipefs on /nfs/var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

Voici le résultat fsck / dev / md3:

root@rescue:~# fsck /dev/md3
fsck from util-linux 2.20.1
e2fsck 1.42.5 (29-Jul-2012)
/home: clean, 370962/50429952 files, 5187714/201693680 blocks

mkswap sur sda2:

root@rescue:~# mkswap /dev/sda2
Setting up swapspace version 1, size = 16382972 KiB
no label, UUID=b375ef52-9434-4298-be4a-38db9da029af

mkswap sur sdb2:

root@rescue:~# mkswap /dev/sdb2
Setting up swapspace version 1, size = 16382972 KiB
no label, UUID=f9318100-c18d-4987-b4e8-6bc58b0c8299

Mettre à jour # 3:

je suppose que Bittylicious Les usages /boot/grub/grub.conf, dans ce cas:

default=0
timeout=5

title CloudLinux Server (2.6.32-458.6.2.lve1.2.30.el6.x86_64)
kernel /boot/vmlinuz-2.6.32-458.6.2.lve1.2.30.el6.x86_64 root=/dev/md1 $
root (hd0,0)
initrd /boot/initramfs-2.6.32-458.6.2.lve1.2.30.el6.x86_64.img
title linux centos6_64
kernel /boot/vmlinuz-2.6.32-358.18.1.el6.x86_64 root=/dev/md1 ro
root (hd0,0)
initrd /boot/initrd-2.6.32-358.18.1.el6.x86_64.img

J'ai aussi essayé de restaurer initramfs. J'ai suivi ce guide:
http://advancelinux.blogspot.c ... .html
</pass></dump></options></type></mount></file>
Invité:

Catherine

Confirmation de:

Il y a tellement de raisons pour lesquelles il ne peut pas démarrer. Nous pourrions tous énumérer un certain nombre de raisons (Et je vais le faire), Mais, à la fin, il doit y avoir une sorte de moyen d'aider votre fournisseur. Même s'ils ont juste lu ce qui est sur la console, cela donnera des conseils importants sur la manière de le réparer.

Mes suggestions pour le moment:

Vous n'avez pas mis en place initramfs / initrd, Mais le pointe toujours

Vous avez spécifié un, mais il ne contient pas de pilotes appropriés pour monter votre système de fichiers racine.

Vous utilisez un hyperviseur qui ne peut pas charger l'image initrd / ramfs / Le noyau dans le format compressé dans lequel il se trouve.

La plupart des fournisseurs non gérés fournissent un soutien, même s'il est payé. Je vous suggère de contrarier, puisque vous passez trop de temps à essayer de le deviner sans accès au noyau.

Mettre à jour 1 - Maintenant que vous avez ajouté des informations fsck, C'est assez simple. Vous essayez de lancer fsck Sur le pénis RAID - Ça ne marchera pas. Ce que vous devez faire, c'est d'abord collecter un tableau RAID (et puis peut-être peut-être courir pour cela fsck).

Pourquoi tu couras toujours fsck sur / dev / sda1? Vous devez probablement faire quelque chose comme:

mdadm --assemble /dev/md1 /dev/sda1 /dev/sdb1

(à condition que sda1 et sdb2 sont vos membres RAID)

Si cela fonctionnait, vous pouvez courir fsck sur / dev / md1. Qu'est-ce que vous avez vraiment besoin de savoir, c'est pourquoi votre système d'exploitation n'a pas assemblé un tableau RAID. Je suppose qu'il est dégradé et vous devez ajouter «bootdegraded» Dans les paramètres de votre noyau.

Mettre à jour 2 - Nous recevrons des informations supplémentaires:

Quand vous avez été réinstallé GRUB, Savez-vous quel est le contenu de votre fichier grub.cfg ou boot.lst, Nous pouvons donc trouver vos options de téléchargement?

Vous avez essayé de reconstruire votre initramfs (update-initramfs -k all -u Seulement pour commencer)

Pour répondre aux questions, connectez-vous ou registre