Vmware ESXi Vlans, Dispositifs Cisco et diffuser des choses étranges

J'ai des problèmes pendant plusieurs jours pour essayer de configurer la configuration correcte.

En ce moment j'ai un commutateur Cisco Catalyst, Cisco Router 2811 et noeud VMware ESXi de 4-8 Machines virtuelles (Linux, BSD, Windows), Chacun d'entre eux est configuré pour utiliser 802.1q, et ils sont regroupés dans 5 Réseaux locaux virtuels.

Ensuite, le nœud est connecté à Cisco Catalyst 2964 VIA PORT D'INTERFACE 0/1 Avec la configuration suivante:

switchport trunk allowed vlan 1-11
switchport mode trunk
switchport nonegottiate

Un plus "Interface vlan" pour tout le monde vlan, À ce stade, des nœuds virtuels avec une adresse statique ipv4 Peut interrupteur ping (nouer vlan 2 peut vérifier la communication avec l'interface Vlan2 Interrupteur, etc.).

Ensuite, je configure l'interface de commutation qui se connectera au routeur Cisco 2811.

switchport trunk allowed  vlan 1-11, 99 
switchport mode trunk
switchport nonegottiate
switchport mode trunk native 99

Dans le routeur Cisco 2811 J'ai créé une piscine dhcpv4 pour tout le monde Vlan (outre 99) Et a commencé à travailler sur l'interface.

interface FastEthernet0/0.1
encapsulation dot1Q 1
ip address 192.168.1.1 255.255.255.0
ipv6 address 2001:DB8:C0CA:1::1/64
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
ipv6 address 2001:DB8:C0CA:2::1/64
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
ipv6 address 2001:DB8:C0CA:3::1/64
!
interface FastEthernet0/0.4
encapsulation dot1Q 4
ip address 192.168.4.1 255.255.255.0
ipv6 address 2001:DB8:C0CA:4::1/64
!
interface FastEthernet0/0.5
encapsulation dot1Q 5
ip address 192.168.5.1 255.255.255.0
ipv6 address 2001:DB8:C0CA:5::1/64
!
interface FastEthernet0/0.99
encapsulation dot1Q 99 native
ip address 192.168.99.1 255.255.255.0

Dans le même temps, j'ai supprimé l'adresse IPv4 statique et j'ai redémarré l'hôte virtuel. À ma surprise, ils ont une adresse IPv6 bien configurée, mais pas IPv4. La prochaine grande surprise pour moi est une tentative de vérifier la passerelle par défaut. IPv6 Chaque hôte: je ne peux pas, mais je peux vérifier la connexion avec des hôtes distants.

Alors je choisis 2 Différents hôtes virtuels et mettre une adresse IPv4 statique, ils ne peuvent pas poser problème à ping leur passerelle locale et même des nœuds distants, cependant DHCP ne fonctionne toujours pas.

À un moment donné, j'allume "paquet debug ip dhcp server" Et je trouve quelque chose de très étrange:

Tous les messages de diffusion sont arrivés à l'interface du routeur fa 0 / 0.1 ** (Et cette interface répond à DHCPOFFER). Dans le même temps, je me suis souvenu d'une autre chose: ** Avant d'envoyer local ping Vérifier IPv6 D'abord avec aide NDP, Utilisation d'un message de multidiffusion

Mais ce n'est pas le cas lorsque vous essayez d'envoyer un package distant.

Pour le moment je suis sûr que VMware ESXi Il a un bon configuré Vlan.

, Le commutateur ressemble à la même chose parce que le routeur peut livrer correctement l'annonce du routeur IPv6» Hôte virtuel. Mais le routeur reçoit la mauvaise livraison de la diffusion (et apparent) Bulletin de multidiffusion et parce que sa réponse est envoyée dans le mauvais vlan (ou ne répond jamais à la demande d'un voisin NDP).

Phrase?

- Ajoutée 25.03.

Je vois ce qui suit:

CDP, Qui est noeud VMWare ESXi obtient de l'état du commutateur que Vlan corbeau 1, et montre la gamme d'adresses IP pour cela vlan. Après un test, j'ai supprimé Vlan1 Du port de l'hôte ESXi Et vérifié à nouveau CDP, La nouvelle gamme d'adresses IP était maintenant de Vlan 2, mais VLAN toujours marqué comme «1», Et maintenant, la vitesse de diffusion des nœuds ne tombe pas dans le routeur.

- Ajoutée 25.03 (La deuxième partie de)

Par la proposition @JelmerS C'est ce qui affiche VMWare:

 esxcfg-vswitch -l
Switch Name Num Ports Used Ports Configured Ports MTU Uplinks
vSwitch0 128 4 128 1500 vmnic0

PortGroup Name VLAN ID Used Ports Uplinks
VM Network 0 0 vmnic0
Management Network 0 1 vmnic0

Switch Name Num Ports Used Ports Configured Ports MTU Uplinks
vSwitch1 128 13 128 1500 vmnic1

PortGroup Name VLAN ID Used Ports Uplinks
Vlan5 5 2 vmnic1
Vlan4 4 3 vmnic1
Vlan2 2 3 vmnic1
Vlan3 3 2 vmnic1

Basculer avec lequel je travaille avec - vSwitch1

qui tous les nœuds sont séparés d'Internet (Un autre est utilisé pour se connecter à distance aux nœuds.)
Invité:

Alice

Confirmation de:

Depuis toutes les demandes DHCP S'inscrire à VLAN 1, Qui est aussi VLAN Par défaut sur l'autoroute à l'hôte ESXi, Je suggérerais que ESXi Ne pas manquer de trafic du tout. Assurez-vous que chaque hôte est connecté à un groupe de ports différent de vswitch, Et définissez la balise appropriée pour chaque port de port. Vérifier
http://kb.vmware.com/selfservi ... 04074
.

Au fait, il est recommandé de ne pas utiliser VLAN 1.

Hannah

Confirmation de:

J'aurais vérifié votre configuration dans ESX.

Façon facile de savoir si votre configuration est cassée ESX, - Ceci est ajouté vlan 99 dans Gi0 / 1 (Vers votre hôte) et l'installer comme votre propre vlan (Comment l'avez-vous fait avec votre routeur). Cela empêchera l'entrée de forfaits non marqués sur vlan, qui se connecte à K. Fa0 / 1.1 votre routeur et confirmez votre configuration vSwitch Besoin de vérification.

Pour répondre aux questions, connectez-vous ou registre