Problème avec la tronc de la tronc Cisco 2960

j'ai Cisco 2960 régi par 12.2 (58) SE2 Avec quatre personnalisés VLAN (10.10.10.0/24 - 10.10.40.0/24) Plus un canal ascendant en ligne 192.168.1.0/24. J'ai allumé le routage et le réseau IP VLAN Aucun problème ne peut-il pas communiquer avec l'autre, mais ma connexion à Internet ne fonctionne pas.

Ma passerelle en ligne - 192.168.1.1, et j'ai une interface (GigabitEthernet0 / 2) sur le commutateur configuré pour 192.168.1.0/24 avec adresse IP 192.168.1.254. J'ai essayé de créer une route par défaut en utilisant:

Route IP 0.0.0.0 0.0.0.0 192.168.1.1

Mais cela ne fonctionne pas.

DANS DHCP J'installe la passerelle par défaut pour chaque VLAN comme adresse .1.

Voici la configuration:

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname myswitch
!
!
no aaa new-model
clock timezone CST -6
system mtu routing 1500
udld aggressive
!
sdm prefer lanbase-routing
!
ip routing
!
ip subnet-zero
!
!
mls qos map cos-dscp 0 8 16 26 32 46 46 56
!
!
macro global description cisco-global
errdisable recovery cause link-flap
errdisable recovery interval 60
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 40
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 40
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 40
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 40
switchport mode access
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/2
switchport access vlan 192
switchport trunk native vlan 192
switchport trunk allowed vlan 10-192
switchport mode trunk

!
interface Vlan1
!
interface Vlan10
ip address 10.10.10.1 255.255.255.0
no ip route-cache
!
interface Vlan20
ip address 10.10.20.1 255.255.255.0
no ip route-cache
!
interface Vlan30
ip address 10.10.30.1 255.255.255.0
no ip route-cache
!
interface Vlan40
ip address 10.10.40.1 255.255.255.0
no ip route-cache
!
interface Vlan192
ip address 192.168.1.254 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.1.1
ip http server
!
ip domain-name domain.internal
ip name-server 10.10.10.2
!
ip dhcp pool vlan10
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 10.10.10.2
domain-name domain.internal
lease 0 1 0
ip dhcp excluded-address 10.10.10.1 10.10.10.10
!
ip dhcp pool vlan20
network 10.10.20.0 255.255.255.0
default-router 10.10.20.1
dns-server 10.10.10.2
domain-name domain.internal
lease 0 1 0
ip dhcp excluded-address 10.10.20.1 10.10.20.10
!
ip dhcp pool vlan30
network 10.10.30.0 255.255.255.0
default-router 10.10.30.1
dns-server 10.10.10.2
domain-name domain.internal
lease 0 1 0
ip dhcp excluded-address 10.10.30.1 10.10.30.10
!
ip dhcp pool vlan40
network 10.10.40.0 255.255.255.0
default-router 10.10.40.1
dns-server 10.10.10.2
domain-name domain.internal
lease 0 1 0
ip dhcp excluded-address 10.10.40.1 10.10.40.10
!
end

À partir de l'interrupteur, je peux facilement entrer sur Internet sans aucun problème, mais aucun des clients connectés au commutateur ne peut. Je soupçonne que ceci est un problème avec ma configuration de port d'essai sur GigabitEthernet0 / 2, Mais je suis un gars serveur, pas un gourou réseau, et je suis un peu exagérant.
Invité:

Alice

Confirmation de:

Avant de lire le reste

Malheureusement, je n'ai pas assez de réputation sur le SO-site pour poser des questions. J'ai donc fait beaucoup d'hypothèses brutes dans la prochaine réponse. Veuillez donner une description détaillée et poser des questions avant de faire des actions sur les problèmes ci-dessous.

Une version de logiciel

Révision - pas la seule information importante - Également important "train" ou "famille de fonctions". Exemple;

 # show version | include image  
System image file is "flash:me340x-metroipaccessk9-mz.122-55.SE5.bin"

Dans cet exemple, j'utilise


metroipaccess

sur

ME3400

-dispositif. Il a des fonctions de routage et peut faire des choses intéressantes différentes.

DANS

Matériel intéressant

Dans ce cas, vous souhaitez utiliser des fonctions de routage. DANS

ip route xxx

L'équipe ne fera rien avec le trafic émanant de clients si vous n'utilisez pas de logiciels de routage, car il s'applique uniquement au trafic "administratif" émanant de l'interrupteur lui-même.

Si vous n'avez pas accès à des logiciels (Les licences ne sont pas bon marché), Mais vous avez un routeur avec support vlan, Tu devrais le faire.

Conception de réseau

En utilisant le routeur

En supposant que vous avez un routeur avec support vlan / trunk

, Créer une interface vlan sur l'appareil et faites-leur toutes partie vrf / vrf-lite, Afin que le routeur puisse passer du trafic entre eux. Faire la route par défaut dans VRF.

Voici l'image de deux manières possibles:
https://i.imgur.com/IH1qDCz.jpg
En fonction de votre câblage de câble, vous pouvez avoir un câble directement du routeur. (ligne rouge au nuage) ou du commutateur (Ligne noire au nuage).

Si vous n'avez pas l'occasion inter-vlan / vrf ...

Soutenir

192.168.1.1

Ceci est un routeur que vous gérez

Développez votre

/24

http://www.wolframalpha.com/in ... 52F22
. Débarrassez-vous de OT. vlans. Vous aurez mille propriétaires possibles là-bas. C'est moche mais AFAICT de ce qui précède, vous vouliez toujours avoir un routage inséparable entre vlan, En utilisant seulement vlan Réduire la taille de votre domaine de diffusion, qui en soi est important, mais si vous n'avez pas le matériel nécessaire , Tu dois faire.

Giselle

Confirmation de:

Vous devez utiliser la commande ip route 0.0.0.0 0.0.0.0 192.168.1.1, Comme vous l'avez mentionné, au lieu d'une équipe existante ip default-gateway. Équipes IP route travailler pour tout le trafic tout en ip default-gateway - Seulement pour le trafic émanant de ce commutateur.

De plus, si tout ce qui est connecté à Gi0 / 2, n'est pas un commutateur configuré sur le coffre que vous ne voulez pas Gi0 / 2 Il était un tronc, vous voulez juste que ce soit un port d'accès.

int gi0/2
switchport mode access
switchport access vlan 192

Et vous devez également vous assurer que 192.168.1.1 Savoir voler voler 10.10.10.0/24, 10.10.20.0/24, 10.10.30.0/24 et 10.10.40.0/24 retour à 192.168.1.254.

Dominique

Confirmation de:

À en juger par ce que vous dites, je ne vois pas le point de ce point:

 interface GigabitEthernet0/2
switchport access vlan 192
switchport trunk native vlan 192
switchport trunk allowed vlan 10-192
switchport mode trunk
..
interface Vlan192
ip address 192.168.1.254 255.255.255.0
no ip route-cache

Vous pouvez juste faire:

interface GigabitEthernet0/2
no switchport
ip address 192.168.1.254 255.255.255.0

Sinon, vous devriez installer le port Gi0 / 2 en tant que port d'accès, ou assurez-vous que l'autre extrémité est soit d'accès, soit elle-même vlan 192.

Effectuer des troncs, vous vous connectez également vlan avec une extrémité distante, qui complique la situation (Si, bien sûr, vous ne le faites pas spécifiquement).

Enfin, comme déjà mentionné, vous avez besoin «ip route», mais non «ip default-gateway».

Pour répondre aux questions, connectez-vous ou registre