"Erreur lors de la lecture du filtre d'entrée SSL» Apache et 443

J'ai un petit problème avec mon apache conf. Lorsque j'ai lu le journal d'erreur, je vois ce qui suit:

[client xxx.xxx.xx.xx] AH01964: Connection to child 1 established (server www.mywebsite.com:443)
[client xxx.xxx.xx.xx] AH01964: Connection to child 6 established (server www.mywebsite.com:443)
[client xxx.xxx.xx.xx] AH01964: Connection to child 10 established (server www.mywebsite.com:443)
[client xxx.xxx.xx.xx] AH01964: Connection to child 15 established (server www.mywebsite.com:443)
[client xxx.xxx.xx.xx] AH01964: Connection to child 18 established (server www.mywebsite.com:443)
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.

Et parfois c'est:

 (70007)The timeout specified has expired: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.

En fait je ne sais pas ... Donc, mon site web est complètement HTTP, Outre deux pages de HTTPS. Voici donc mon hôte virtuel:

<virtualhost *:80="">
ServerName mywebsite.com
Redirect permanent / [url=http://www.mywebsite.com/]http://www.mywebsite.com/[/url]
</virtualhost>
<virtualhost *:80="">
ServerName www.mywebsite.com
ServerAlias img.mywebsite.com
ServerAdmin xxx
DocumentRoot /home/mywebsite/www/public
<directory home="" mywebsite="" www=""></directory>
Options Indexes Multiviews FollowSymlinks
AllowOverride All
Require all granted
ErrorDocument 403 [url=http://www.google.com/]http://www.google.com/[/url]

<directory home="" mywebsite="" private="" public="" resource="" www=""></directory>
Require all denied
ErrorDocument 403 [url=http://www.mywebsite.com/]http://www.mywebsite.com/[/url]

<location "="" robots.txt"="">
Require all granted
</location>

LogLevel info
ErrorLog ${APACHE_LOG_DIR}/mywebsite_error.log
CustomLog ${APACHE_LOG_DIR}/mywebsite_access.log combined
</virtualhost>
<ifmodule mod_ssl.c="">
<virtualhost *:443="">
ServerName www.mywebsite.com
DocumentRoot /home/mywebsite/www/public
<directory home="" mywebsite="" www=""></directory>
Options Indexes FollowSymlinks Multiviews
AllowOverride all
Require all granted

LogLevel info
ErrorLog ${APACHE_LOG_DIR}/mywebsite_error.log
CustomLog ${APACHE_LOG_DIR}/mywebsite_access.log combined

SSLEngine on
SSLCertificateFile ./mywebsite.crt
SSLCertificateKeyFile ./mywebsite.key
SSLCertificateChainFile ./intermediate.crt
</virtualhost>
</ifmodule>

Alors, où ai-je commis une erreur? Je ne peux pas savoir ... Pouvez-vous m'aider?

remercier :)
Invité:

Conrad

Confirmation de:

je lis ça Apache Ne pas soutenir SSL Sur des hôtes virtuels basés sur des noms, uniquement sur des hôtes virtuels basés sur IP. Je l'ai changé:

 <virtualhost *:443="">

par:

 <virtualhost 192.168.1.1:443="">

Pour le moment, il semble fonctionner, je ne sais pas si cette solution est bonne, mais il n'y a pas d'erreurs ...
</virtualhost></virtualhost>

Camille

Confirmation de:

Une autre exigence - Ajoutez la ligne suivante à la fin des blocs de directive SSL Port. 443 VirtualHost.

SetEnv nokeepalive ssl-unclean-shutdown

Comme indiqué
http://wiki.indie-it.com/index ... ailed
:

Agathe

Confirmation de:

Pour moi, une solution ridiculement simple à cette erreur comme suit. (Cette erreur est apparue après ajout de fichiers. / Dossiers de qualité root):

chown www-data: /var/www -R
chmod 755 /var/www -R

Pour répondre aux questions, connectez-vous ou registre